Unable to perform migration: ImportError: No module named yaml

Created:

2016-12-12 03:46:06 UTC

Modified:

2017-08-08 13:21:56 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to perform migration: ImportError: No module named yaml

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux

Symptoms

Getting the following error message when trying to run Plesk Migrator on the server:

Error: Error on call plesk-migrator with args [generate-migration-list, /usr/local/psa/var/modules/panel-migrator/sessions/20160711152445/config.ini, --skip-services-checks, --include-existing-subscriptions, --async]

CODE: 1

STDOUT:

STDERR:
Traceback (most recent call last):
File "/usr/local/psa/admin/sbin/modules//panel-migrator/plesk-migrator", line 16, in <module>
from parallels.core.cli.migration_cli import run
File "/usr/local/psa/admin/plib/modules/panel-migrator/backend/lib/python/parallels/core/cli/migration_cli.py", line 7, in <module>
from parallels.core.cli.common_cli import Command, CommandTypes, \\
File "/usr/local/psa/admin/plib/modules/panel-migrator/backend/lib/python/parallels/core/cli/common_cli.py", line 20, in <module>
from parallels.core.utils.log import Log
File "/usr/local/psa/admin/plib/modules/panel-migrator/backend/lib/python/parallels/core/utils/log.py", line 4, in <module>
import yaml
ImportError: No module named yaml

Cause

plesk-py27-pyyaml is either not installed or corrupted.

Resolution

Reinstall Plesk Migrator extension via Plesk autoinstaller.

Have more questions? Submit a request
Please sign in to leave a comment.