Configuration errors are shown after subscription creation. Apache failes to start due missing logs

Created:

2016-12-12 03:45:47 UTC

Modified:

2017-08-08 13:36:20 UTC

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Configuration errors are shown after subscription creation. Apache failes to start due missing logs

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

Apache is down after new subscription creation. Configuration errors are shown right after subscription creation.

Selinux is enabled and vhosts directory is changed to custom one.

Similar errors can be found in /var/log/plesk/panel.log with enabled debug log:

DEBUG [panel] Service_Driver_Exception: nginx: [emerg] open() "/home/vhosts/system/plesktest123.tld/logs/proxy_access_ssl_log" failed (13: Permission denied)

In /var/log/audit/audit.log it is possible to find nginx denied errors.

Cause

Plesk selinux module is not designed to work with custom vhosts directory.

Resolution

Change vhosts directory back to original /var/www/vhosts or disable selinux using # setenforce 0

Please provide your suggestion for new functionality on User Voice:

https://plesk.uservoice.com/forums/184549-feature-suggestions

The top-ranked suggestions are likely to be included in the next versions of Plesk. You can get the information about the updates in our products in the following public sources:

http://kb.plesk.com/subscriptions/index.html - knowledge base, each product update comes with corresponding KB article;
http://kb.plesk.com/rss/?p=PLESK - RSS feeds

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