Why does DKIM validation of my mail fail

Created:

2016-12-12 03:45:36 UTC

Modified:

2017-08-08 13:36:13 UTC

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Why does DKIM validation of my mail fail

Applicable to:

  • Plesk Onyx for Linux
  • Plesk Onyx for Windows
  • Plesk 12.5 for Windows

Symptoms

External service for DKIM validation (for example DKIMvalidator.com reports that result of the validation invalid because the public key is not available after DNS lookup.

Cause

  • DNS service in Plesk is not adjusted properly (domain zone could not be visible for the DKIM validation service)
  • Used mail domain name is not real (i.e. mydomain.com, example.com, etc...)
  • DKIM related DNS resource records in the used domain zone are broken or removed

Resolution

Try to use the following steps:

  • Make sure that you are using a real domain name to send email from it.

  • Make sure that DNS lookup says that your mail domain is resolved properly.

  • Correct DNS settings if some errors are found there.

  • Make sure that DKIM related DNS resource records are inside of your domain zone.

  • Disable and enable again mail signing using DKIM in Plesk if some errors are found there

  • Wait for the DNS propagation period. The changes you have made will be loaded, applied and synchronized by DNS (it may take up 48 hours, but mostly faster)

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