Cannot install/use Softaculous on Ubuntu 16: /opt/psa/admin/htdocs/modules/softaculous/load.php requires the ionCube PHP Loader ioncube_loader_lin_7.0.so

Created:

2016-12-12 03:44:16 UTC

Modified:

2017-08-08 13:14:11 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Cannot install/use Softaculous on Ubuntu 16: /opt/psa/admin/htdocs/modules/softaculous/load.php requires the ionCube PHP Loader ioncube_loader_lin_7.0.so

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

  • Softaculous extension opens with the following error:

    Site error: the file /opt/psa/admin/htdocs/modules/softaculous/load.php requires the ionCube PHP Loader ioncube_loader_lin_7.0.so to be installed by the website operator. If you are the website operator please use the ionCube Loader Wizard to assist with installation.
  • However, this module is loaded to system PHP:

    # php -v
    PHP 7.0.8-0ubuntu0.16.04.3 (cli) ( NTS )
    Copyright (c) 1997-2016 The PHP Group
    Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v6.0.6, Copyright (c) 2002-2016, by ionCube Ltd.
    with Zend OPcache v7.0.8-0ubuntu0.16.04.3, Copyright (c) 1999-2016, by Zend Technologies
  • An attempt to remove this extension and install it back produced the following error:

    Error: Failed to install the extension:
    Execution of /opt/psa/tmp/module36ggLn/plib/scripts/pre-install.php failed with exit code 1 and the output:
    Softaculous is not compatible with PHP 7+

Cause

Softaculous extension is not compatible with PHP 7+.

Resolution

    There are the following workarounds:
  • Use Application Vault under Home > Tools & Settings > Applications & Databases . Application Vault has the same functionality as Softaculous.

  • install ioncube loader library using steps from article #115000228505
Have more questions? Submit a request
Please sign in to leave a comment.