Unable to update Plesk: Mailman update failed current stop runlevel overrides LSB defaults

Created:

2016-12-12 03:43:10 UTC

Modified:

2017-08-08 13:33:18 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to update Plesk: Mailman update failed current stop runlevel overrides LSB defaults

Applicable to:

  • Plesk Onyx for Linux

Symptoms

Unable to install Plesk updates:

dpkg: error processing archive /var/cache/apt/archives/mailman_1%3a2.1.20-1ubuntu0.1_amd64.deb (--unpack):
subprocess new pre-installation script returned error exit status 1
No updates required.
insserv: warning: current stop runlevel(s) (0 1 6) of script `mailman' overrides LSB defaults (empty).
Errors were encountered while processing:
/var/cache/apt/archives/mailman_1%3a2.1.20-1ubuntu0.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Cause

System mailman package is outdated

Workaround

  1. Create a backup of the following directory:

    cp -p -r /var/lib/mailman/qfiles ./
  2. Remove all files in /var/lib/mailman/qfiles directory

  3. Run Plesk installer again. If it does not help, upgrade system packages:

    # apt-get upgrade

For further assistance, contact your system administrator as Plesk does not ship mailman_1%3a2.1.20-1ubuntu0.1_amd64.deb package.

Have more questions? Submit a request
Please sign in to leave a comment.