Greylisting defers all emails from Office365 accounts

Created:

2016-12-12 03:41:39 UTC

Modified:

2017-08-17 17:58:24 UTC

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Greylisting defers all emails from Office365 accounts

Applicable to:

  • Plesk 12.0 for Linux

Symptoms

Messages from Office365 mail accounts get deferred by greylisting handler with the following error in /var/log/maillog :

/usr/lib64/plesk-9.0/psa-pc-remote[956]: DEFER during call 'grey' handler
/usr/lib64/plesk-9.0/psa-pc-remote[956]: Message aborted.
postfix/smtpd[2028]: 61AF6E27BAB4: milter-reject: DATA from mail-*.outbound.protection.outlook.com[10.10.10.10]: 451 4.7.1 Service unavailable - try again later; from=<1@officeaccount.com> to=<1@pleskaccount.com> proto=ESMTP helo=<*.outbound.protection.outlook.com>

The message may be delivered within 1-2 days after all, or may not be delivered at all.

The following message may be delivered to the sender (Office365 mail account):

Final-recipient: RFC822; 1@pleskaccount.com
Action: failed
Status: 5.4.0
X-Supplementary-Info: < #5.4.300 smtp;550 5.4.300 Message expired -> 451 4.7.1 Service unavailable - try again later>

Cause

Emails from *protection.outlook.com are usually sent from a multiple Microsoft IPs so every new retry will go from a different IP. This causes greylisting treat every new retry as a new message, thus, there is a delay in message delivery until the same pair of email/IP is logged.

Resolution

Set up server-wide white list for Office 365 domains - a list of hosts whose mail will be accepted without greylisting check-ups:

/usr/local/psa/bin/grey_listing -u -domains-whitelist add:*outbound.protection.outlook.com

Note: exact patterns (statements after add: option) may differ.

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