Upgrade failed on the OS with installed ScriptCase, Plesk is inaccessible with 500 Internal server error

Created:

2016-12-12 03:40:19 UTC

Modified:

2017-08-16 17:07:46 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Upgrade failed on the OS with installed ScriptCase, Plesk is inaccessible with 500 Internal server error

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.x for Linux

Symptoms

Upgrade to Plesk 12.5 failed.
Following error is in the /var/log/plesk/install/plesk_12.5.30_installation.log file:

After end of upgrade for 'core' (stage 'prep') following actions are registered as failed:  20150326132522-php_upgrade_system_handlers_pre_12_1_18.

sw-engine -v fails with the following error:

[root@plesk ~] # sw-engine -v
sw-engine: /opt/nm/v6/zend/lib/libldap_r-2.4.so.2: no version information available (required by /opt/nm/v6/zend/lib/libpq.so.5)
sw-engine: /usr/lib64/libcrypto.so.10: version `OPENSSL_1.0.0' not found (required by opt/nm/v6/zend/lib/libpq.so.5)
sw-engine: /usr/lib64/libssl.so.10: version `OPENSSL_1.0.0' not found (required by /opt/nm/v6/zend/lib/libpq.so.5)

Cause

ScriptCase is installed on the server in opt/nm/v6/ directory.
Its PHP engine is conflicting with the sw-engine .

Resolution

  1. Rename or delete symbolic link /opt/nm/v6/zend/lib/libpq.so.5.4 to the file /opt/nm/v6/zend/lib/libpq.so.5.4 :

    [root@plesk ~] # mv /opt/nm/v6/zend/lib/libpq.so.5.4 /opt/nm/v6/zend/lib/libpq.so.5.4.backup
  2. Create new symbolic link /opt/nm/v6/zend/lib/libpq.so.5.4 to the file /usr/lib64/libpq.so.5 (usually belongs to postgresql-libs package):

    [root@plesk ~] # ln -s  /usr/lib64/libpq.so.5 /opt/nm/v6/zend/lib/libpq.so.5.4
  3. Restart the upgrade using Plesk Installer.

Have more questions? Submit a request
Please sign in to leave a comment.