Unable to install php 7: php55w-common conflicts with php-common-5.4.16-36.3.el7_2.x86_64

Created:

2016-12-12 03:40:01 UTC

Modified:

2017-08-08 13:30:12 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to install php 7: php55w-common conflicts with php-common-5.4.16-36.3.el7_2.x86_64

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

Unable to install php 7 via Plesk autoinstaller:

Attempt to remove 'php55w-common' to resolve conflict has succeeded
Exception: Failed to solve dependencies:
php55w-common conflicts with php-common-5.4.16-36.3.el7_2.x86_64

System php55 was installed from webtatic.repo , webtatic.repo is disabled and CentOS-Base.repo is enabled.

Cause

Package conflict from CentOS and webtatic repositories.

Resolution

  1. Disable CentOS-Base repository:

    # mv /etc/yum.repos.d/CentOS-Base.repo  /etc/yum.repos.d/CentOS-Base.repo.bk
  2. Make sure that webtatic.repo is enabled.

  3. Install php 7 via Plesk.

Have more questions? Submit a request
Please sign in to leave a comment.