How to install a legacy Plesk version

Follow

Comments

10 comments

  • Avatar
    Viktor Diehl

    I wanted to instal version 17.0.17 but unfortunately that does not work anymore, man googles and searches the whole plesk forum / page and follows every (excuse) shit instructions and man can not install except version 17.8.11 -.- but I need 17.0. 17 with php 5.6 and not 17.8.11 where only php 7+ is there are too many cms systems not yet running on php7 !!! and many of my clients also want to use php 5.6

    -1
    Comment actions Permalink
  • Avatar
    Denis Bykov

    @viktor

    `# plesk-installer --all-versions` still works and Plesk Onyx 17.0 can be chosen, unless Plesk Onyx 17.8 is already installed or Debian 9 is used.
    Plesk Onyx 17.8 is the only Plesk version which supports Debian 9.

    0
    Comment actions Permalink
  • Avatar
    Viktor Diehl (Edited )

    @denis

     

    on my debian system i tried, but is not working -.- i can only install 17.8.11 but no other version 

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    @Viktor, am I correct that you are using Debian 9? In this case, this is expected as only Plesk.

    0
    Comment actions Permalink
  • Avatar
    Jeremy A Gruver

    # ./plesk-installer --show-all-releases < Very useful, helped me install 17.5 on a blank centos server :)

    0
    Comment actions Permalink
  • Avatar
    Alisa Kasyanova

    @Jeremy A Gruver
    Thank you for the feedback, good to know that you have found the article helpful :)

    0
    Comment actions Permalink
  • Avatar
    Contact

    Hi,

    Thanks for this help.

    In my case, it don't work . 
    I am recovering the hosting from an old site and i need php 5.3.
    My host provider allow only install ubuntu 18 min

    How can i do ?

    Thanks

    0
    Comment actions Permalink
  • Avatar
    Kuzma Ivanov

    Hi Contact

    Modern operating systems do not support PHP 5.6 and lower versions. Check out this KB article for details.

    You can install a custom PHP version and register it in Plesk using these instructions.
    0
    Comment actions Permalink
  • Avatar
    Daniel Ddungu

    Hello @Kuzma Ivanov

    I followed the procedure but it throws an error 

    0
    Comment actions Permalink
  • Avatar
    Kuzma Ivanov

    Hi Daniel Ddungu!

    According to the error message, the icu-devtools package is missing in your system.

    Try installing it with this command:

    # apt-get install -y icu-devtools

    Once installed, start Plesk Installer again.

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request