After installing VZ application template of some Plesk component, Panel shows error: Warning: web server configuration is broken.

Created:

2016-11-16 13:26:06 UTC

Modified:

2017-04-24 11:35:41 UTC

0

Was this article helpful?


Have more questions?

Submit a request

After installing VZ application template of some Plesk component, Panel shows error: Warning: web server configuration is broken.

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.5 for Linux

Symptoms

After installing versionless Plesk Panel application template (e.g. ' pp-bind ', ' pp-postfix ', 'pp-webmail '), the following error is observed in the Panel:

Warning : failed to perform deferred action : watchdog_reconfigure
PHP Fatal error: Call to a member function deleteAdditionalConfigFiles() on a non-object in /usr/local/psa/admin/plib/api-common/Httpdmng.php on line 148

Warning: web server configuration is broken. We will try to repair it. This operation can take a lot of time, please do not interrupt the process.

Unable to rebuild web server configuration, possible there are broken domains
Trying to reconfigure web-server configurations skipping broken domains... PHP Fatal error: Call to a member function deleteAdditionalConfigFiles() on a non-object in /usr/local/psa/admin/plib/api-common/Httpdmng.php on line 148

Resolution

To fix the issue run the bootstrapper utility with ' repair ' key:

# /usr/local/psa/bootstrapper/pp11.5.3-bootstrapper/bootstrapper.sh repair

Cause

When installing the versionless template, installer downloads and installs latest available Plesk packages from repository. If even some particular package like ' pp-bind ' is installed via ' vzpkg ' after the new version of Plesk Panel was released, it will trigger the whole Plesk Panel upgrade due to packages dependencies.

Upgrade scripts have failed during the web server reconfiguration.

Have more questions? Submit a request
Please sign in to leave a comment.