Access denied error is shown when access Plesk login page

Created:

2016-11-16 13:24:45 UTC

Modified:

2017-04-24 11:03:35 UTC

1

Was this article helpful?


Have more questions?

Submit a request

Access denied error is shown when access Plesk login page

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 12.0 for Windows
  • Plesk 12.5 for Windows

Symptoms

After upgrading while logging in to Plesk as admin, an 'Access denied' error message is received:

Access denied.
The operation you were performing failed. You can retry the operation with or without changing its parameters. You may also want to report this problem to our support so that we could help you as soon as possible.

The following error can be found in %plesk_dir%\\admin\\logs\\php_error.log :

Exception: Access is denied.
file: C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\plib\\Lock\\Manager\\Hierarchical.php
line: 105
code: 0
trace: #0 C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\plib\\Lock\\Manager\\Hierarchical.php(105): LockManagerClient->__construct()
#1 C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\plib\\Lock\\Manager\\Hierarchical.php(172): Plesk\\Lock\\Manager_Hierarchical->_getClient()
#2 C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\plib\\Lock\\Manager\\Hierarchical.php(136): Plesk\\Lock\\Manager_Hierarchical->_applyLock('', Object(Plesk\\Lock\\Resource))
#3 C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\plib\\Lock\\Manager.php(80): Plesk\\Lock\\Manager_Hierarchical->lock(Object(Plesk\\Lock\\Resource), '')
#4 C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\plib\\Lock.php(34): Plesk\\Lock\\Manager->lock(1, Array, '', Array)
#5 C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\plib\\Db\\Table\\Dictionary\\ServiceNodeEnvironment.php(80): Plesk\\Lock::write(Object(Plesk\\Lock\\Object_NodeService), '', Array)
#6 C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\plib\\Service\\Driver\\Packages\\Windows.php(98): Db_Table_Dictionary_ServiceNodeEnvironment->sync(false)
#7 C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\htdocs\\login_up.php3(85): Service_Driver_Packages_Windows->sync()
#8 {main}

Cause

Permissions for %plesk_dir%\\admin was incorrectly set during the upgrade.

Resolution

  1. Make sure psaadm use has Read & write permissions:

    cd %plesk_dir%
    icacls admin | findstr psaadm
    WIN-6JC4VI0KVI0\\psaadm:(OI)(CI)(RX)

    set them if not:

    icacls admin /grant psaadm:(OI)(CI)(RX)
  2. Install the latest Plesk microupdates:

    "%plesk_bin%"\\ai.exe --select-product-id panel --select-release-current --reinstall-patch --install-component base
  3. Make sure that there is no DailyMaintenance task running before the upgrade was started. Terminate them, if any.

Have more questions? Submit a request
Please sign in to leave a comment.