Applicable to:
- Plesk for Windows
Symptoms
-
A website or webmail is unavailable with the error message:
PLESK_INFO: HTTP Error 503. The service is unavailable.
-
There are no errors in domain's error log in Plesk at Domains > example.com > Logs.
-
The following error message appears at Domains > example.com > Dedicated IIS Application Pool for Website:
PLESK_ERROR: Error: Your server's applications pool is not running, but it was not stopped through Plesk. There might be some issue with IIS. You can restart the application pool
Cause
The website's IIS application pool is stopped.
Resolution
Start the website's application pool:
Via Plesk
-
Go to Domains > example.com > Dedicated IIS Application Pool for Website.
-
Click Switch Off.
-
Click Switch On.
Via RDP connection
-
Connect to a Plesk server via RDP.
-
Start a command prompt as an Administrator and run the command:
C:\> plesk repair web example.com -y
Comments
1 comment
Okay, IIS was interrupted but what caused this interruption? It is not clear why. My application works without a problem but eventually it is interrupted two or three times in periods of 20 to 25 minutes. Is it related to the number of concurrent users? Does some resource like memory become overloaded and the interruption happens? The Plesk does not allow you to create an automatic restart action when this occurs. It is only solved by entering Plesk and starting the IIS Application again.
Please sign in to leave a comment.