Plesk upgrade failed: Packages excluded due to repository priority protections

Refers to:

  • Plesk for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:23:45 UTC

Modified:

2017-02-10 10:06:17 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade failed: Packages excluded due to repository priority protections

Symptoms

Plesk upgrade failed with the following message:

XX packages excluded due to repository priority protections

Cause

Some packages are held by more than one repository. The priorities plugin chooses packages from the highest-priority repository, excluding duplicate entries from other repos.

Resolution

Disable priorities plugin by editing /etc/yum/pluginconf.d/priorities.conf file the following way:

# cat /etc/yum/pluginconf.d/priorities.conf
[main]
enabled = 0

Launch the upgrade again.

Have more questions? Submit a request
Please sign in to leave a comment.