Courier-IMAPs issue after system upgrade: SSL routines:SSL3_GET_RECORD:wrong version number

Created:

2016-11-16 13:23:43 UTC

Modified:

2017-08-08 13:40:07 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Courier-IMAPs issue after system upgrade: SSL routines:SSL3_GET_RECORD:wrong version number

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

After upgrading the operating system, problems with courier-imaps service appeared:

www courier-imapd: couriertls: read: error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca

OR

root@www:~# openssl s_client -starttls imap -crlf -connect localhost:143
...
error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number:s3_pkt.c:348

Or the following errors appear in /var/log/maillog :

root@www:/usr/share/courier-imap# zgrep couriertls /var/log/maillog*
/var/log/maillog:Sep 19 11:25:02 www courier-pop3d: couriertls: read: error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac
/var/log/maillog:Sep 19 11:25:02 www courier-pop3d: couriertls: read: error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac

Cause

Courier-IMAP service misconfiguration.

Resolution

  1. Remove the component packages from the system:

    root@www:~#  dpkg --list|grep courier
    ii plesk-courier-imap-driver 12.5.30-debian8.0.build1205150826.19 amd64 Plesk v12.5.30 Courier-IMAP driver
    ii psa-courier-authlib 0.66.2-debian8.0.15081914 amd64 Courier authentication library
    ii psa-courier-imap 4.16.1-debian8.0.15081914 amd64 Courier-IMAP v4.16.1 IMAP server
    ii psa-courier-unicode 1.2-debian8.0.15072015 amd64 Courier Unicode Library

    # dpkg --purge plesk-courier-imap-driver psa-courier-imap psa-courier-authlib psa-courier-unicode
    # mv /etc/courier-imap /etc/courier-imap.bak
  2. Install Courier-IMAP component via Plesk installer:

    # /usr/local/psa/admin/sbin/autoinstaller
Have more questions? Submit a request
Please sign in to leave a comment.