Applicable to:
- Plesk for Windows
Symptoms
-
Unable to backup/restore a snapshot for Web Presence Builder in Plesk for Windows due to one of the following errors:
PLESK_ERROR: Invalid Snapshot
PLESK_ERROR: Unable to restore website
-
One of the following errors appear in the
%plesk_dir%admin\logs\plesklog_sitebuilder.log
file:CONFIG_TEXT: [EMERG] /sitebuilder/JsonApi/ PleskUtilException: filemng failed:
Unexpected error at execute "C:\Program Files (x86)\Parallels\Plesk\admin\bin\filemng.exe" u0088675 base64 C:\inetpub\vhosts\example.com\httpdocs\data/snapshots/6e6c622a415484ff7a23038329113589.php(RunTime::RunAsUser::run line 221)(Error code 1)file: C:\Program Files (x86)\Parallels\Plesk\admin\plib\Service\Agent.phpline: 243code: 0
CONFIG_TEXT: ERR [1] Exception: PHP Warning: filesize(): stat failed for C:/Program Files (x86)/Parallels/Plesk/PrivateTemp/sb94E3.tmp.zip; File: C:\Program Files (x86)\Parallels\Plesk\admin\plib\Service\Driver\Filesystem\Plesk\Windows.php, Line: 271file: C:\Program Files (x86)\Parallels\Plesk\admin\plib\Smb\Exception\Syntax.phpline: 57code: 0
CONFIG_TEXT: [EMERG] /sitebuilder/JsonApi/ SB_Site_Snapshot_Exception: invalidSnapshot
file: C:\Program Files (x86)\Plesk\sb\include\SB\Site\Snapshot.php
line: 258
code: 0 91.204.25.4 https://example.com:8443/sitebuilder/Editor
Cause
The issue is caused by two product bugs #PPPM-3483 and #PPPM-4869 which will be fixed in future product updates.
Resolution
As a workaround connect to the server via RDP and perform the following actions (depending on Plesk version installed):
Warning: prior installing of patches below, make sure that the website on which snapshot is tried to be restored is available via HTTP.
-
Download and unpack the archive with the patched file
Target.php
. -
Create a backup of the original file
Target.php
located in%plesk_dir%sb\include\SB\Extension\PP
. -
Copy the patched file
Target.php
into%plesk_dir%sb\include\SB\Extension\PP
. -
Backup/restore a snapshot again.
-
Download and unpack the archive with the patched file
Target.php
. -
Create a backup of the original file
Target.php
located in%plesk_dir%sb\include\SB\Extension\PP
. -
Copy the patched file
Target.php
into%plesk_dir%sb\include\SB\Extension\PP
. -
Backup/restore a snapshot again.
Comments
1 comment
I have tried to use the file for Plesk Onyx to solve this same issue on Plesk Obsidian - and it seems to work.
I did needed to make some more changes though, but that might be particular to my installation. Changing to PHP 8.0 Fast CGI eventually solved the issue, I think WPB's failure to download or restore a snapshot was linked to a specific PHP configuration setting. But in any case, using the solution for Onyx does not seem to hurt Obsidian.
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