New files of configuration for Apache web server were not built: low memory_limit value

Created:

2016-11-16 13:23:37 UTC

Modified:

2017-08-16 16:18:01 UTC

0

Was this article helpful?


Have more questions?

Submit a request

New files of configuration for Apache web server were not built: low memory_limit value

Applicable to:

  • Plesk 11.x for Linux

Symptoms

The following error is displayed in the web interface, when trying to manage a subscription:

Error: New files of configuration for Apache web server were not built due to errors in configuration templates. The detailed error message was e-mailed to you, so please check the e-mail, fix the errors, and click here to retry generating configuration.

In ' /var/log/sw-cp-server/error\\_log ' the following error appears:

2012-09-26 17:38:06: (connections.c.309) SSL: 1 error:1407609C:SSL routines:SSL23\\_GET\\_CLIENT\\_HELLO:http request    PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 7680 bytes) in /usr/share/aps\\_php/aps\\_php.php on line 9600    PHP Warning: Releasing semaphore 1 in request cleanup; File: Unknown, Line: 0

Cause

The subscription management opeation failed due to PHP memory limit exceeding.

Resolution

Increase the ' memory_limit ' parameter in ' /usr/local/psa/admin/conf/php.ini ', to 256M, or even to 1024M, depending on the domains quantity and RAM available on the server.

Have more questions? Submit a request
Please sign in to leave a comment.