SMTP does not work on port 587 in MailEnable

Created:

2016-11-16 13:23:36 UTC

Modified:

2017-08-16 17:35:53 UTC

0

Was this article helpful?


Have more questions?

Submit a request

SMTP does not work on port 587 in MailEnable

Applicable to:

  • Plesk 11.x for Windows
  • Plesk 12.0 for Windows
  • Plesk 12.5 for Windows

Symptoms

It is not possible to connect to port 587 on Windows server with MailEnable.

However, MailEnable is configured properly:

Mailenable SMTP settings:
SMTP -> Properties -> "Inbound" tab -> "Port Settings" Settings
Set:
SMTP port = 25
Submission port = 587

Cause

This issue is likely caused by an incorrect firewall configuration - port 587 is filtered.

Resolution

Open "Windows Firewall with Advanced Security" on the server and create a new rule:

Accept all inbound connections on port 587.

The following steps are required to open a custom port:

1. Open the start menu
2. Type firewall
3. Open Windows Firewall with Advanced Security
4. Open Inbound Rules
5. New Rule...
6. Choose Port type
7. Choose TCP, and enter the required port - in our case, 587
8. Choose to Allow the connection
9. Choose all three profiles (Domain+Private+Public)
10. Enter a custom rule name, e.g. "Port 587"
11. Press finish.

Make sure that you can connect with telnet. For example:

    # telnet 1.2.3.4 587
Trying 1.2.3.4...
Connected to 1.2.3.4.
Escape character is '^]'.
220 domain.tld ESMTP MailEnable Service, Version: 6.5-- ready at 05/06/14 20:38:39

You could also see knowledgebase article #213932745 to check the other ports used by Parallels Plesk Panel.

Have more questions? Submit a request
Please sign in to leave a comment.