Could not validate backup with German symbols

Created:

2016-11-16 13:23:20 UTC

Modified:

2017-04-24 11:18:23 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Could not validate backup with German symbols

Applicable to:

  • Plesk 11.5 for Windows
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Symptoms

Could not create backup if special German symbols are used in Web Server Settings Additional nginx directives.

Steps to reproduce:

  1. Create subscription in Plesk 11.5
  2. Go to Websites & Domains -> Web Server Settings -> Additional nginx directives
  3. Insert the following lines:

    Beeinflussung der Konfiguration von mod_fcgid für die Ausführing von lang laufenden
    Skripten zum Import von Fahrzeugdaten und Bilddateien von domain.tld

Backup fails with the following error: -- Runtime error: The check dump failed with code '1'. The dump can contain invalid data! at /usr/local/psa/admin/bin/plesk_agent_manager line 1230. --

Daily backup fails after Plesk upgrade to 11.5 version:

            ERROR dec61e3f-e62b-8dd5-4ed1-2bd40acaead2 Runtime error: The check dump failed with code '1 '. The dump can contain container invalid data!

The following error is shown in pmmcli.log ( /usr/local/psa/PMM/logs/pmmcli.log ):

            parallels_domain.tld_info_1309132333.xml: Failed to load XML document.
Line 535 Position 61 fatal error: Input is not proper UTF-8, indicate encoding !
Bytes: 0xFC 0x72 0x20 0x64

Cause

This is Plesk bug with ID #PPPM-867 was fixed in Panel 11.5.30 MU#23.

Resolution

Domain name (domain.tld) and file name (parallels_domain.tld_info_1309132333.xml) are mentioned in error:

  1. Find the file mentioned in error, it should be located in dump directory.

  2. Find non-ascii symbols in it, command below will give you the line number and will highlight non-ascii chars in red:

            # grep --color='auto' -P -n "[\\x80-\\xFF]" parallels_domain.tld_info_1309132333.xml

Go to Domains->domain.tld->Websites & Domains tab.

  1. Open Web Server Settings menu and remove symbols found on step 2 from Additional nginx directives .

  2. Try to create backup again.

Have more questions? Submit a request
Please sign in to leave a comment.