Applicable to:
- Plesk for Windows
Symptoms
-
Unable to log in as a domain's FTP user:
CONFIG_TEXT: Cannot log in, home directory inaccessible
Or:
CONFIG_TEXT: 530 User cannot log in, home directory inaccessible
-
It is not possible to upload files using FTP:
CONFIG_TEXT: An error occurred copying a file the FTP Server. Make sure you have permission to put files on the server.
Details:
200 Type set to I.
227 Entering Passive Mode(203,0,113,2,255,28).
550 index.html: Access is denied -
When logging in locally from the server, the following error is shown:
CONFIG_TEXT: C:\Users\Administrator>ftp example.com
Connected to example.com.
220 Microsoft FTP Service
User (example.com:(none)): plesktest
331 Password required
Password:
530-User cannot log in, home directory inaccessible.
Win32 error: The system cannot find the path specified.
Error details: File system returned an error.
530 End
Login failed.
ftp> -
Unable to open a folder in File Explorer:
CONFIG_TEXT: An error occurred opening that folder on the FTP Server. Make sure you have permission to access that folder.
Details:
The connection with the server was reset
Possible causes
There are several possible causes. This error occurs if any of the following statements are true:
-
Server hostname is longer than 15 symbols.
-
A domain is resolved to a different IP address which is not configured in Plesk.
-
The user does not exist in Conections pane under IIS > Sites > <IP_address> > localuser.
-
IP Address mapping is not configured correctly.
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A user does not have permission to read the home directory under IIS > <IP_address> > localuser > example.com > FTP Authorization Rules.
-
FTP_ROOT_D
value is set incorrectly or missing from Windows registry underHKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\PLESK\PSA Config\Config
. -
The incorrect path is specified under IIS > Sites > Right click on <IP_address> > Manage FTP Site > Advanced Settings > Physical Path (tab) . The path should not include the space sign.
Depending on the version of IIS, the path may vary. For example, in IIS version 6 it will be: IIS 6 > FTP Sites > IP > Properties > Home Directory > Local path. If there is no relevant path specified, correct it so that it redirects to
C:\inetpub\vhosts\Servers\1
-
The FTP user link file
C:\inetpub\vhosts\Servers\8\localuser\system_user\example.com\
is missing FTP user permissions. -
The FTP user has no access to a domain home directory or is not listed in the access list.
-
The FTP user home directory name begins or ends with space.
-
FTP site is absent from IIS.
- The hostname used for connecting to the FTP server resolves to IP address which differs from the one configured in Plesk.
-
Other possible causes are described in this Microsoft article: Error message in IIS: "530 User cannot log in. Login failed."
Troubleshooting steps
-
Change the hostname for Windows Server 2008:
1.1. Right-click the My Computer icon and choose Properties .
1.2. Select the Computer Name tab and click on the Change button.
1.3. Restart the server.To change the hostname on Windows Server 2012 and newer:
1.1. Go to Control Panel > System > Change Settings > Change... and insert another Computer name (which should not contain more than 15 characters).
1.2 Restart the server. -
Check that a domain is resolving to the same IP that has been configured in Plesk. You can use the following command:
nslookup example.com
If your server is behind NAT use the internal IP address that forwarded to external in NAT rules.
-
Make sure that FTP user exists in IIS > <IP_address> > localuser . If it does not exist, reconfigure FTP server according to step 5.
-
Check that the user is able to read the contents of the home directory. IIS manager > Sites > Right click on %IP_address% > Manage FTP Site > Advanced Settings > Physical Path
If not, reconfigure the FTP site using the instructions in the next step.
-
Reconfigure FTP server.
For Plesk 8 and Plesk 9 only: Repair permissions on the home folders of the problem domain. This can be done using the Control Panel: go to Domains, mark the problem domain, and click on Check permissions.
Before reconfiguring FTP make sure that main domain of subscription is active.
-
For Plesk 11.0 and earlier: Use the Plesk command line tool
ftpmng.exe
as follows:C:\> "%plesk_bin%\ftpmng.exe" --remove-vhost --vhost-name=example.com "%plesk_bin%\ftpmng.exe" --reconfigure-vhost --vhost-name=example.com
-
For Plesk 11.5: Use the utility
repair.exe
as follows:C:\> "%plesk_cli%\repair.exe" --reconfigure-ftp-site -webspace-name example.com
If this issue occurs with every domain, you can repair the FTP configuration for all domains using the following commands:
-
For Plesk 11.0 and earlier: Use the Plesk command line tool
ftpmng.exe
as follows:C:\> "%plesk_bin%\ftpmng.exe" --remove-all"%plesk_bin%\ftpmng.exe" --reconfigure-all
-
For Plesk 11.5 and Plesk 12 Use the utility
repair.exe
as follows:C:\> "%plesk_cli%\repair.exe" --reconfigure-ftp-sites
-
For Plesk 12.5.30 and Plesk Onyx use
repair
utility:C:\> plesk repair ftp
Note: The above commands will not affect website functionality. However, any custom FTP configuration will vanish.
-
-
Open Registry Editor (
Start > Run > regedit
), navigate toHKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\PLESK\PSA Config\Config
, check theFTP_ROOT_D
path and verify it corresponds to the existing physical directory. If the key does not exist, create it (the key type is String). -
Check the physical path for FTP sites in IIS > Sites > <IP_address> > Basic settings > Physical Path. This should be part of
FTP_ROOT_D
from the previous step. -
Verify that the system user folder (FTP user) of a subscription exists in the FTP site path (see Cause). For example,
C:\inetpub\vhosts\Servers\8\localuser\system_user\example.com\
. If it does not, find a folder which contains this folder, for exampleC:\inetpub\vhosts\Servers\7\
, and change the Physical Path accordingly. -
Verify that the FTP user link file
C:\inetpub\vhosts\Servers\8\localuser\system_user\example.com\
has Read&Execute permission for the FTP user (system_user). -
Verify that FTP site exist under IIS > Sites > <IP_address>. If this site does not exist, go to Plesk > Tools & Settings > IP Addresses > Reread IP .
-
Install the latest Windows server updates via System > Windows Updates > Install. Reboot system if necessary.
-
If nothing helped, enable debug logging to get additional information on the issue:
Comments
2 comments
In my case, the 503 FTP problem was due to another additionnal cause, caused by Plesk however.
The 503 FTP problem appeared after I restored a subscription from a Plesk Backup.
As all the solutions listed on this page did not succeed, I went to "Computer Management > Users and Groups" (I am running a Windows 2012 R2 Web Server).
I discovered that the user account in charge of running the for service for this website was "DISABLED" !
Obviously, I re-enabled this user, and Boom : The FTP access was available anew, solving and vanishing the 503 FTP error.
The cause is that this user account was disabled by Plesk while restoring the backup, then Plesk forgot to re-enable it.
I am not sure if this issue will appear wether you check or do not check the "Disable website while restoring from backup" on the Plesk panel).
I hope that this issue was solved in Plesk Onyx. This happened to me in Plesk 12.5 latest update at time of writing (25th, Novembre, 2018).
Fo what it worth, I am sure this comment will help some of you, folks ;)
Hi @Alex Laforge,
Thanks for sharing!
Bu the way, I cannot recall such issues with Plesk Onyx.
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