Migration fails: Unable to import file as dump: The file you are trying to upload is not a valid backup file (errcode 152)

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 12.5 for Windows

Created:

2016-11-16 13:22:24 UTC

Modified:

2017-02-19 13:13:17 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Migration fails: Unable to import file as dump: The file you are trying to upload is not a valid backup file (errcode 152)

Symptoms

  1. Migration between Plesks fails with error:
    [ERROR] Failed to import backup dumps to target panel's repository
    Cause: Failed to import backup XML: errcode must be '0' (no errors) or '116' (backup sign error).
    Output of pmmcli utility:
    <?xml version="1.0" encoding="UTF-8"?>
    <response>
    <errcode>152</errcode>
    <errmsg>Unable to import file as dump: The file you are trying to upload is not a valid backup file</errmsg>
    </response>
    That is a critical error, migration was stopped.

From %plesk_dir%\\PMM\\logs\\import-2015-11-04-03-06-24-163\\import.txt :

    [2015-11-04 03:06:33.958| 6592] INFO: Executing utility: "C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\bin\\pre10-backup-convert" --convert -source "C:/Program Files (x86)/Parallels/Plesk/Backup\\migra_info_1511040106.xml" -destination "C:/Program Files (x86)/Parallels/Plesk/Backup"
[2015-11-04 03:06:36.664| 6592] INFO: The utility succesfully executed.
...
[2015-11-04 03:06:38.040| 6592] INFO: Validate content files backup_branding_1511040107.zip at dir
[2015-11-04 03:06:38.150| 6592] INFO: File 'backup_branding_1511040107.zip' does not found in the dump
  1. Branding is enabled on source Plesk.

Cause

This is a software issue with internal id PMT-2331

Resolution

  1. Remove Plesk Migrator extension:

    Plesk > Extensions > Tick the "Plesk Migrator" checkbox > Remove

  2. Install the latest version of Plesk Migrator extension:

    Plesk > Extensions > Extension Catalog > Install Plesk Migrator

    Also can be done via CLI:

    plesk installer  --select-release-current --install-component pmm
Have more questions? Submit a request
Please sign in to leave a comment.