Cannot enable Sitebuilder support for Plesk domain: "Error occurs when trying to attach current ip of the domain to sitebuilder"

Created:

2016-11-16 13:22:20 UTC

Modified:

2016-12-21 20:34:04 UTC

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Cannot enable Sitebuilder support for Plesk domain: "Error occurs when trying to attach current ip of the domain to sitebuilder"

Symptoms

I have Sitebuilder registered in Plesk Control Panel, but when I try to enable Sitebuilder for my domain ( Domains > DOMAIN.TLD > Setup > Create and publish Web site using Sitebuilder ) the following error occurs and Sitebuilder left disabled.

Warning: The following error occured in Sitebuilder:
Error occurs when trying to attach current ip of the domain to sitebuilder
Information: Web hosting service for the domain your-domain.com was set up.

Cause

  1. Sitebuilder license key allows 1 hosts and Plesk Control Panel is unable to add new IP address.

    Server >  License Management > Plan Info > Maximum number of hosts
  2. Sitebuilder license key has unlimited maximum number of hosts, but IP address of Plesk domain was already added by admin to Sitebuilder hosts.

    Server > Hosts

Resolution

  1. Sitebuilder License Key should be updated to allow more hosts. Contact Parallels sales to include multi-server publishing.

  2. Delete IP address from Sitebuilder hosts, when Plesk domain is enabled in Sitebuilder the IP address will be added back.

Additional Information

Usually when new IP address is added to Sitebuilder hosts by admin it is added to admin's plan also and the problem does not occur. However it may happen that IP address does not exist in plan of admin, in this case it should be deleted from Sitebuilder hosts,

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