How do I manually upgrade Plesk license?

Created:

2016-11-16 13:21:54 UTC

Modified:

2017-08-08 13:39:41 UTC

0

Was this article helpful?


Have more questions?

Submit a request

How do I manually upgrade Plesk license?

Applicable to:

  • Plesk

Symptoms

My Plesk license was not automatically upgraded after I upgraded my server. How do I upgrade my license now?

Cause

Temporary connectivity issue between your server and licensing server (Key Administrator). As a result, Plesk did not upgrade the license to newer version.

Resolution

You can manually upgrade your license at the following page:

https://central.plesk.com/public/license-management/#upgrade-plesk

The Plesk License Upgrade System will upgrade your license by one version at a time, so upgrade of license to more than one version will require multiple upgrades through this system.

For example, if you have a Plesk 9 LEASE license and want to upgrade it to Plesk 11, you need to perform two license upgrades (9.x->9.5->10.x/11).

Retail(Purchased) license for Plesk 9 will be upgraded to version 11 in three steps: 9.x->9.5->10.x->11

To upgrade eligible license you need to know:

  • Your Plesk license number (example: PLSK.12345678.1234).
  • The email address of your account in Plesk licensing system, where the license is stored.

IMPORTANT : license upgrade is possible only if your license has valid SUS. You can find more details about SUS here:

https://kb.plesk.com/111

Have more questions? Submit a request
Please sign in to leave a comment.