Plesk upgrade failed: libapr-1.so.0 is needed by (installed) subversion-1.6.11-10.el5_8.i386

Created:

2016-11-16 13:21:53 UTC

Modified:

2017-08-16 17:05:28 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade failed: libapr-1.so.0 is needed by (installed) subversion-1.6.11-10.el5_8.i386

Applicable to:

  • Plesk 11.x for Linux
  • Plesk 12.0 for Linux

Symptoms

  1. Plesk upgrade fails with the following error:

    Fatal error during packages installation: [u'ERROR with rpm_check_debug vs depsolve:', 'libapr-1.so.0 is needed by (installed) subversion-1.6.11-10.el5_8.i386', u'Please report this error at http://bugs.centos.org/set_project.php?project_id=16&ref=http://bugs.centos.org/bug_report_page.php?category=yum']
    YumRPMCheckError: [u'ERROR with rpm_check_debug vs depsolve:', 'libapr-1.so.0 is needed by (installed) subversion-1.6.11-10.el5_8.i386', u'Please report this error at http://bugs.centos.org/set_project.php?project_id=16&ref=http://bugs.centos.org/bug_report_page.php?category=yum']
  2. Both x86_64 and i386 versions of the subversion-1.6.11-10.el5_8 package are installed:

    # rpm -qa | grep subversion
    subversion-1.6.11-10.el5_8.i386
    subversion-1.6.11-10.el5_8.x86_64

Cause

Conflicts of different versions of subversion-1.6.11-10.el5_8 package

Resolution

  1. Check server architecture:

    # arch
    x86_64
  2. Remove invalid subversion-1.6.11-10.el5_8 package:

    # rpm -e subversion-1.6.11-10.el5_8.i386 --nodeps
  3. Continue with upgrade.

Have more questions? Submit a request
Please sign in to leave a comment.