HTTP 404 error message when accessing webmail on any domain

Refers to:

  • Plesk 10.4 for Windows
  • Plesk 12.5 for Linux
  • Plesk 11.0 for Windows
  • Plesk 11.5 for Windows
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Windows
  • Plesk 12.5 for Windows

Created:

2016-11-16 13:21:45 UTC

Modified:

2016-12-21 20:32:51 UTC

0

Was this article helpful?


Have more questions?

Submit a request

HTTP 404 error message when accessing webmail on any domain

Symptoms

  1. An HTTP 404 error message is shown when accessing webmail on any domain.

Cause

This error means that the website responsible for Webmail, "webmail (default)" is not configured correctly or absent in IIS.

Resolution

The following commands need to be launched to fix the problem:

For Parallels Plesk Panel (Plesk) 11.0.9 and earlier:

    "%plesk_bin%\\websrvmng.exe" --reconfigure-webmail
"%plesk_bin%\\defpackagemng.exe" --fix --type=webmail.horde

Note: The webmail.horde value is taken by default. If you are using another webmail engine, it is necessary to check this under the following registry key :

HKLM\\SOFTWARE\\Plesk\\PSA Config\\Config\\Packages\\webmail

For Plesk 11.5.30 and later:

  1. If Webmail Horde site is not configured correctly in IIS reconfigure Webmail Horde site settings:

    "%plesk_cli%\\repair.exe" --reconfigure-web-site -web-site-name <domain.com>
    "%plesk_cli%\\repair.exe" --reconfigure-webmail-sites
  2. If Webmail Horde site is absent in IIS.

    a) Recover the Webmail Horde site:

    "%plesk_bin%\\websrvmng.exe" --add-webmail-site --webmail=horde

    b) Reconfigure Webmail Horde site settings:

    "%plesk_cli%\\repair.exe" --reconfigure-web-site -web-site-name <domain.com>
    "%plesk_cli%\\repair.exe" --reconfigure-webmail-sites
Have more questions? Submit a request
Please sign in to leave a comment.