Plesk upgrade by EZ templates failed if plesk-mail-pc-driver and qmail psa-qmail-rblsmtpd packages are installed.

Created:

2016-11-16 13:21:00 UTC

Modified:

2017-04-24 11:38:26 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade by EZ templates failed if plesk-mail-pc-driver and qmail psa-qmail-rblsmtpd packages are installed.

Applicable to:

  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux

Symptoms

Upgrade by EZ templates on conflict:

Error: plesk-mail-pc-driver conflicts with psa-qmail
Error: plesk-mail-pc-driver conflicts with psa-qmail-rblsmtpd
Error: /usr/share/vzyum/bin/yum failed, exitcode=1

Cause

psa-mail-qc-driver package from older version of Plesk has no conflict with psa-qmail and psa-qmail-rblsmtpd packages and these packages can be installed simultaneously, on maildriver switching from psa-qmail to postfix by EZ templates for example. But newer versions of plesk-mail-pc-driver have such conflict and cannot be installed until psa-qmail and psa-qmail-rblsmtpd are installed.

Resolution

Upgrade by lates version of autonstaller .

Another solution:

Remove psa-qmail and psa-qmail-rblsmtpd packages before upgrade.

Have more questions? Submit a request
Please sign in to leave a comment.