Plesk upgrade fails: Public key for package.rpm is not installed

Refers to:

  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:20:51 UTC

Modified:

2016-12-21 20:30:43 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade fails: Public key for package.rpm is not installed

Symptoms

Upgrade to Plesk 12 fails with error:

atomic/gpgkey                                            | 1.3 kB     00:00
Fatal error during packages installation: Public key for php-odbc-5.4.29-35.el5.art.i386.rpm is not installed
YumBaseError: Public key for php-odbc-5.4.29-35.el5.art.i386.rpm is not installed

ERROR: Failed to run the Yum utility.

Cause

GPG validation for repository fails.

Resolution

  1. Disable the GPG validation for repository that you use for downloading files (e.g. Atomic repo):

    # grep -i gpgcheck /etc/yum.repos.d/atomic.repo
    gpgcheck = 0
  2. Launch Plesk upgrade.

Have more questions? Submit a request
Please sign in to leave a comment.