php-cgi.exe process exited unexpectedly. Unable to load dynamic library "php_interbase.dll" - The specified module could not be found

Created:

2016-11-16 13:20:24 UTC

Modified:

2017-08-16 16:56:32 UTC

0

Was this article helpful?


Have more questions?

Submit a request

php-cgi.exe process exited unexpectedly. Unable to load dynamic library "php_interbase.dll" - The specified module could not be found

Applicable to:

  • Plesk 11.x for Windows
  • Plesk 11.x for Linux
  • Plesk 12.0 for Windows
  • Plesk 12.5 for Windows

Symptoms

The website is displaying an "Internal error":

HTTP Error 500.0 - Internal Server Error
C:\\Program Files (x86)\\Parallels\\Plesk\\Additional\\PleskPHP53\\php-cgi.exe - The FastCGI process exited unexpectedly

'php-cgi.exe -v' fails with the below warning:

PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\Program Files (x86)\\Parallels\\Plesk\\Additional\\PleskPHP53\\ext\\php_interbase.dll' - The specified module could not be found.

Cause

'C:\\Program Files (x86)\\Parallels\\Plesk\\Additional\\PleskPHP53\\ext\\php_interbase.dll' requires a 'fbclient.dll' library, which is not present on a Windows servers by default.

Resolution

Either install Firebirdsql package , or comment out the following extension in PHP configuration file ( 'C:\\Program Files (x86)\\Parallels\\Plesk\\Additional\\PleskPHP53\\php.ini' ):

;extension=php_interbase.dll

NOTE: In the above example we assumed that PHP 5.3 is used. In case if you use a different version, modify the 'php.ini' i na corresponding location.

Have more questions? Submit a request
Please sign in to leave a comment.