Psa-proftpd package cannot be installed due to conflict with proftpd-basic package

Created:

2016-11-16 13:19:47 UTC

Modified:

2017-08-16 18:24:58 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Psa-proftpd package cannot be installed due to conflict with proftpd-basic package

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.x for Linux
  • Plesk 12.0 for Linux

Symptoms

Unable to install Parallels Panel Web Hosting Component using autoinstaller on the Debian 7.2. The following error appears in /tmp/autoinstaller3.log :

Unpacking psa-proftpd (from .../psa-proftpd_1.3.4c-debian7.0.build115130619.21_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/psa-proftpd_1.3.4c-debian7.0.build115130619.21_i386.deb (--unpack):
trying to overwrite '/etc/pam.d/proftpd', which is also in package proftpd-basic 1.3.4a-5+deb7u1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

Cause

It means that the previously installed proftpd server conflicted with psa-proftpd_1.3.4c-debian7.0.build115130619.21_i386.deb package.

It is possible that you have installed it manually before Plesk was installed on the server.

    dpkg --list | grep proftpd
proftpd-basic

Resolution

  1. Remove the existing proftpd-basic package:

    dpkg --remove  proftpd-basic
  2. Install the Panel Web Hosting Component again using autoinstaller.

Have more questions? Submit a request
Please sign in to leave a comment.