Applicable to:
- Plesk for Linux
Symptoms
-
Emails sent through a mailing list (mailman) to external mailboxes (Gmail, Outlook, Yahoo!, etc.) are not received.
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One of the following error messages appears in
/var/log/maillog
:CONFIG_TEXT: NOQUEUE: reject: RCPT from localhost[::1]: 454 4.7.1 list@example.com: Relay access denied;
from=list@example.com to=john_doe@example.net proto=ESMTP helo=<mail.example.com>
CONFIG_TEXT: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 554 5.7.1
-
One of the following error messages appears in
/var/log/mailman/smtp-failure
:CONFIG_TEXT: delivery to list@example.com failed with code -1: Server not connected
delivery to john_doe@example.com failed with code -1: [Errno 104] Connection reset by peer
CONFIG_TEXT: delivery to john_doe@example.com failed with code 553: sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)
Cause
localhost IPv4 and IPv6 addresses are not whitelisted.
Resolution
Add localhost IPv4 127.0.0.1 and IPv6 ::1/128 addresses to the white list:
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Go to Tools & Settings > Mail Server Settings > White List.
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Click Add Network > add 127.0.0.1 to the IP address/mask field > click OK.
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Click Add Network > add ::1/128 to the IP address/mask field > click OK.
Additional Information
With localhost IP addresses 127.0.0.1 and ::1/128 being white-listed, the limits on outgoing mail will not work. The corresponding warning will appear at Tools & Settings > Mail Server Settings:
PLESK_WARN: Warning: The limits on outgoing mail will not work for mail senders whose IP addresses are in the mail server's white list. For example, if there is localhost (127.0.0.0 / 8, ::1 / 128) in the white list, all mail from the local server will be successfully sent regardless of the limitations. Mail senders can use either local IP addresses (websites and custom scripts hosted on the local server) or external ones (customers who send mail from mail clients installed on their computers or mobile devices). To make the limits work for all mail senders (both local and external), remove all IP addresses and networks from the white list. Note that removing localhost (127.0.0.0 / 8, ::1 / 128) from the white list might disrupt the operation of websites and scripts that send mail from this server. For details about limitations on outgoing mail, see the Administrator's Guide, Protection from Outbound Spam.
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