Plesk update fails with error: Unable to start websrvmng.exe: Access is denied.

Created:

2016-11-16 13:19:12 UTC

Modified:

2017-08-16 16:43:04 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk update fails with error: Unable to start websrvmng.exe: Access is denied.

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.x for Windows
  • Plesk 11.x for Linux
  • Plesk 12.0 for Windows
  • Plesk 12.5 for Windows

Symptoms

Plesk upgrade is failing with error:

Installing packages
installing Parallels Panel WebSite...
MSI: Error! Critical action 'Configure Parallels Panel site...' failed:
Unable to start ("C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\bin\\websrvmng.exe" --configure-plesk-website): (5) Access is denied.
Failed to install 'C:\\ParallelsInstaller\\parallels\\PANEL-WIN_11.5.30\\dist-msi-Mi
crosoft-2003-i386\\plesk-site.msi': Fatal error during installation. (Error code
1603)
ERROR: The installation of the package 'plesk-site' failed with code 1603. (inst
all: installing Parallels Panel WebSite...)
Not all packages were installed.
Please, contact product technical support.

OR

Microupdates installation fails with the "can't apply patch" errors like the following ones:

Unable to set the object (C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\plib\\backup\\.aiupd_5128\\cuPleskBackup.php.old) owner: (2) The system cannot find the file
specified.

OR

Unable to set the object (C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\htdocs\\server\\.aiupd_5306\\configure.php3.old) owner: (2) The system cannot find the file
specified.

OR

Unable to set the object (C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\panel\\application\\resources\\languages\\en-US\\controllers\\server\\.aiupd_2247\\secure-passwords.php.old) owner: (2) The system cannot find the file specified.

Cause

Antivirus software running on the server prevents successful installation.

Resolution

Disable antivirus software and re-run failed operation:

  • for microupdates installation:

    "%plesk_bin%\\ai.exe" --select-product-id panel --select-release-current --upgrade-installed-components
  • for Plesk upgrade:

     "%plesk_bin%\\ai.exe" --console
Have more questions? Submit a request
Please sign in to leave a comment.