Cannot login into Plesk on port 8443

Created:

2016-11-16 13:17:52 UTC

Modified:

2017-08-17 13:56:42 UTC

3

Was this article helpful?


Have more questions?

Submit a request

Cannot login into Plesk on port 8443

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux

Symptoms

Plesk is not accessible on secure port 8443 , however non-secure connection on port 8880 works fine.Localhost connection via lynx to https://your_ip:8443 is also available.

Cause

1. Port 8443 is blocked somewhere within a network or ISP.

2. Default Plesk port is misconfigured.

Resolution

  1. Make sure port 8443 is not used by Apache on the hardware node* if Plesk is installed inside a container:

    # grep -E -r '8443' /etc/httpd/*
  2. Make sure port 8443 is not used by any of nginx' virtual hosts:

    # grep -E -r '8443' /etc/nginx/plesk.conf.d/vhosts/*
  3. Check whether or not iptables on both HN* and in the container has rules regarding port 8443 :

    # iptables --list | grep 8443

    Open ports if it's needed:

    # iptables -I INPUT 1 -p tcp -m multiport --dports 8880,8443 -j ACCEPT
  4. Check which daemons are associated with port 8443. It has to be sw-cp-server:

    # lsof -i tcp:8443

    COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
    sw-cp-ser 11572 root 7u IPv4 453293705 0t0 TCP *:8443 (LISTEN)
    sw-cp-ser 11572 root 9u IPv6 453293707 0t0 TCP *:8443 (LISTEN)
    sw-cp-ser 11573 sw-cp-server 7u IPv4 453293705 0t0 TCP *:8443 (LISTEN)
    sw-cp-ser 11573 sw-cp-server 9u IPv6 453293707 0t0 TCP *:8443 (LISTEN)

    If the command above shows only rows with TYPE IPv6 check /etc/sw-cp-server/conf.d/plesk.conf file and make sure that server{} location contains the following entry:

    listen 8443 ssl;
  5. Try to change the default port to another value and see if it works. If it does then the issue is most definitely within the network.

  6. Contact your server administrator or ISP to resolve the issue.
Have more questions? Submit a request
Please sign in to leave a comment.