Plesk system utility does not work: "The system cannot find the file specified. (Error code 2) at Unable to connect to pipe"

Refers to:

  • Plesk 11.0 for Windows
  • Plesk 11.5 for Windows
  • Plesk 12.0 for Windows
  • Plesk 12.5 for Windows
  • Plesk 9.x and below for Windows
  • MT:2053f640b9219125c5e1bbe30be07e7b
  • MT:504a5dd91e21aeb3cd8818371bbf7c09
  • MG:66b66b2397fdf370bc0e245dae34a194
  • MG:c75af5673ac31fb771aa1c4059d3a987

Created:

2016-11-16 13:17:38 UTC

Modified:

2017-02-13 06:12:52 UTC

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Plesk system utility does not work: "The system cannot find the file specified. (Error code 2) at Unable to connect to pipe"

Symptoms

I cannot set the Plesk password and all Plesk utilities return this error:

"%plesk_bin%\\defpackagemng" --help
The system cannot find the file specified. (Error code 2) at Unable to connect to pipe \\\\.\\pipe\\P_61d3bd7d-6fa0-414e-b43f-e18328c19482

"%plesk_bin%\\plesksrvclient" -get
The system cannot find the file specified. (Error code 2) at Unable to connect to pipe \\\\.\\pipe\\P_61d3bd7d-6fa0-414e-b43f-e18328c19482

Cause

Plesk Panel service is not running.

Resolution

Go to Windows -> Services and make sure that the following system services are running:

Plesk Control Panel Service
Plesk Management Service
Plesk SQL Service

You can also restart all the Panel-managed services within Plesk Panel Services Monitor :

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