Plesk upgrade fails with a Segmentation fault error

Created:

2016-11-16 13:17:06 UTC

Modified:

2017-08-16 18:33:17 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade fails with a Segmentation fault error

Applicable to:

  • Plesk 10.x for Linux
  • Plesk for Linux
  • Plesk 11.x for Linux
  • Plesk 9.x for Linux

Symptoms

Plesk update on CentOS 5.x or RedHat 5.x from 10.4 to 11.0.9 fails with a Segmentation fault error.

/usr/local/psa/admin/bin/autoinstaller --select-release-id PLESK_11_0_9
Actual result that you got : Do you want to continue?
Type either Yes or No:
[N]: Yes
Retrieving information about the installed packages...
...
Determining the packages that need to be installed.
Segmentation fault

Cause

This issue is caused by the internal autoinstaller package resolver.

Resolution

Disable the internal autoinstaller package resolver by executing the following command:

echo 'USE_YUM="YES"' >> /root/.autoinstallerrc

This command forces autoinstaller to use yum instead of the internal resolver.

Have more questions? Submit a request
Please sign in to leave a comment.