Unable to change locale: the specified interface language pack files do not exist in the system

Created:

2016-11-16 13:16:44 UTC

Modified:

2017-04-24 11:40:46 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to change locale: the specified interface language pack files do not exist in the system

Applicable to:

  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Symptoms

Plesk shows error while enabling language:

Unable to change locale: the specified interface language pack files do not exist in the system

Checking Plesk language package results in:

# rpm -V plesk-l10n
missing /usr/local/psa/admin/plib/locales/es-ES/conhelp_es-ES.php
missing /usr/local/psa/admin/plib/locales/es-ES/messages_es-ES.php

Cause

Corrupted Plesk language package.

Resolution

  1. Download Plesk language package from Plesk repository:

    # wget http://autoinstall.plesk.com/<Plesk_version>/<distro_version>/base/plesk-l10n-<version>.rpm

    As an example, for Plesk 12 on CentOS 6 x64 it will be:

    http://autoinstall.plesk.com/PSA_12.0.18/dist-rpm-CentOS-6-x86_64/base/plesk-l10n-12.0.18-cos6.build1200150825.10.noarch.rpm
  2. Reinstall the package:

    # rpm -Uvh plesk-l10n-<version>.rpm
Have more questions? Submit a request
Please sign in to leave a comment.