Unable to log in to domain control panel: The page isn't redirecting properly

Created:

2016-11-16 13:15:29 UTC

Modified:

2017-04-24 11:41:33 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to log in to domain control panel: The page isn't redirecting properly

Applicable to:

  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk

Symptoms

  1. Unable to log in to domain control panel, Plesk redirects in looping.

  2. After logging in using the domain name, the hosting panel shows an error:

    The page isn't redirecting properly

Cause

Subdomain has incorrect owner (client that domain belongs to), defferent from main domain owner:

    mysql> select name,id,cl_id,vendor_id from domains where name like '%test%';
+-----------------------------------+----+-------+-----------+
| name | id | cl_id | vendor_id |
+-----------------------------------+----+-------+-----------+
| domain.tld | 1 | 5 | 5 |
| test123.domain.tld | 2 | 6 | 5 |
+-----------------------------------+----+-------+-----------+

Resolution

Set the subdomains owner ( cl_id ) as domains owner id( cl_id ):

  1. To correct the subdomains owner, create backup of psa database:

    mysqldump -u admin -p`cat /etc/psa/.psa.shadow` psa > ~/psa.`date +%F_%H:%M`.sql
  2. Log in to MySQL:

    mysql -uadmin -p`cat /etc/psa/.psa.shadow ` psa
  3. Update the correct owner id:

    mysql> update domains set cl_id=5 where id=2;
    Query OK, 1 row affected (0.18 sec)
    Rows matched: 1 Changed: 1 Warnings: 0

Note: for Plesk installations running on MS SQL server, log in to MS SQL Management Studio to apply the above solution

Have more questions? Submit a request
Please sign in to leave a comment.