Plesk upgrade failed: Configuration variable not found: APS_DB_DRIVER_LIBRARY

Refers to:

  • Plesk 10.4 for Linux
  • Plesk 11.5 for Linux

Created:

2016-11-16 13:15:02 UTC

Modified:

2016-12-27 11:57:27 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade failed: Configuration variable not found: APS_DB_DRIVER_LIBRARY

Symptoms

Plesk Control Panel shows the error after Plesk upgrade:

    PleskFatalException: Configuration variable not found: APS_DB_DRIVER_LIBRARY (Conf.php:61)

Cause

APS_DB_DRIVER_LIBRARY variable is absent in /etc/psa/psa.conf.

Resolution:

Check that APS_DB_DRIVER_LIBRARY variable exists in /etc/psa/psa.conf. If it is absent, please add parameter as below:

    [root@test]#cat /etc/psa/psa.conf | grep -i aps
# APS Controller
APS_DB_DRIVER_LIBRARY /usr/lib/libmysqlserver.so.2
Have more questions? Submit a request
Please sign in to leave a comment.