Custom ModSecurity module may break Apache after installation of Plesk ModSecurity.

Refers to:

  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:14:56 UTC

Modified:

2016-12-21 20:17:02 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Custom ModSecurity module may break Apache after installation of Plesk ModSecurity.

Symptoms

Custom ModSecurity module is installed on Plesk server. How it may affect server if I decide to install Plesk ModSecurity module? Do they conflict each other?

Resolution

Plesk ModSecurity will conflict with custom ModSecurity module. Please pay attention that custom mod_security will not affect Plesk upgrade itself. But if you decide to install Plesk ModSecurity module along with custom one, it may break Apache. Websites may not work as well as Apache itself.

NOTE: If you plan to use Plesk ModSecurity module, please uninstall custom ModSecurity module before installation of Plesk's one as they may conflict each other.

Please read more about Plesk ModSecurity module in documentation .

Have more questions? Submit a request
Please sign in to leave a comment.