Applicable to:
- Plesk for Windows
Symptoms
-
Unable to create a database dump in Plesk > Domains > example.com > Databases > Export Dump:
mysqldump: Got error: 1045: Access denied for user 'admin'@'localhost' (using password: YES) when trying to connect
-
Attempts to manage a customer's MySQL databases or remove mailbox produces errors:
Error: Connection to the database server has failed because of network problems: Try to establish connection failed
Error: Connection to the database server has failed because the supplied account does not possess administrative privileges: Access denied for user 'admin'@'localhost' (using password: YES)
-
The MySQL server is marked red on the Tools & Settings > Database Servers screen.
Cause
Plesk stores an incorrect MySQL server administrator password.
Resolution
To solve the issue and reconnect Plesk to the MySQL server do the following:
-
Connect to the server using RDP.
-
Edit the MariaDB configuration file
%plesk_dir%Databases\MySQL\my.ini
and add the lineskip-grant-tables
to the[mysqld]
section and save it using text editor:[mysqld]
skip-grant-tables -
Restart the MariaDB server (but not "Plesk SQL Server"), running on port 3306 using the Plesk Services Monitor, which can be started from the Windows Start menu.
Note: Plesk Services Monitor could also be started using the next cmd.exe command:
C:\> "%plesk_dir%\admin\bin\traymonitor.exe"
-
Log into MySQL without the password:
"%plesk_dir%\MySQL\bin\mysql.exe" -P3306
-
Reload the grant-tables policies by running the next command:
FLUSH PRIVILEGES;
- Update/recreate the user by specifying a new password using the next command:
C:\> grant all privileges on *.* to 'admin'@'localhost' identified by 'new_password' with grant option;
Note: Make sure to replace 'new_password' with a new password of choice:
-
Tell the database server to reload the grant tables by issuing the FLUSH PRIVILEGES command;
FLUSH PRIVILEGES;
-
Remove the
skip-grant-tables
from the MySQL configuration file(%plesk_dir%Databases\MySQL\my.ini
) and restart the service again as in Step 3. -
Log in to the Plesk interface, go to the database server management settings ( Tools & Settings > Database Servers ) and open the server's settings:
-
On the opened page click the "Settings" button and specify new the password, that was set in Step 6:
Comments
4 comments
Where can I finde the Plesk Services Monitor in LINUX?
@Alberto Garcia for Linux systems check the articles below:
https://support.plesk.com/hc/en-us/articles/213376789
https://support.plesk.com/hc/en-us/articles/213364309
Thanks I am still having problems.
With the second Link I have this error message
ERROR 1045 (28000): Access denied for user 'admin'@'localhost' (using password: YES)
And with the first link the following error:
[2017-08-28 07:29:11] ERR [panel] SQLSTATE[HY000] [1045] Access denied for user 'admin'@'localhost' (using password: YES):
0: /opt/psa/admin/externals/Zend/Db/Adapter/Pdo/Abstract.php:144
Zend_Db_Adapter_Pdo_Abstract->_connect()
...
ERROR: Zend_Db_Adapter_Exception: SQLSTATE[HY000] [1045] Access denied for user 'admin'@'localhost' (using password: YES) (Abstract.php:144)
exit status 1
@Alberto Garcia Have you tried to add skip-grant-tables directive to my.cnf file, restart the mysql service and reset the password for admin? Also, if there were upgrade of mysql server recently, check error log of mysql service, the message should be self-explanatory. If the issue still persists I recommend to contact Technical Support directly - https://www.plesk.com/contact-support
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