IP address cannot be deleted through IP addresses management because check-box is grayed-out

Created:

2016-11-16 13:14:43 UTC

Modified:

2017-04-24 11:41:58 UTC

0

Was this article helpful?


Have more questions?

Submit a request

IP address cannot be deleted through IP addresses management because check-box is grayed-out

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Windows
  • Plesk 9.x and below for Linux

Symptoms

An IP address that is not used by any client or domain cannot be deleted in:

Tools and Settings > IP addresses

The check-box near IP address is grayed-out and cannot be selected.

Cause

The IP address 123.123.123.123 is grayed-out on the IP addresses management page because it is the default address for Plesk or is being used in the DNS zone of some domain.

Resolution

The IP address is grayed-out because it is the default address for Plesk:

Run the following command to get the default IP address for Plesk:

    # MYSQL_PWD=`cat /etc/psa/.psa.shadow` mysql -u admin psa -Ne"select IP_Addresses.ip_address from IP_Addresses, misc where misc.val=IP_Addresses.id and misc.param='def_ip_id'"
------------------+
| ip_address |
+-----------------+
| 123.123.123.123 |
+-----------------+

The default IP address is set during initial configuration. Reconfigure Plesk to change the default IP address.

If Plesk is configured, the parameter psa_configured is set to "true" in the psa.misc table:

    # MYSQL_PWD=`cat /etc/psa/.psa.shadow` mysql -u admin psa -Ne"select * from misc where param='psa_configured'"
+----------------+------+
| param | val |
+----------------+------+
| psa_configured | true |
+----------------+------+

To perform initial configuration, change the psa_configured parameter to "false":

    # MYSQL_PWD=`cat /etc/psa/.psa.shadow` mysql -u admin psa -Ne"update misc set val='false' where param='psa_configured'"

Then log out and log back in to Plesk. The initial configuration page is opened just after logging in:

    Warning: Fill the requested information into the appropriate fields. This information is required for Plesk to work.

Preferences ------------------------
Default IP Address -----------------
Shared IP addresses ----------------
Administrator's Preferences --------

Select another IP address in the drop-down menu near the Default IP Address , fill in the other required information, and click "OK" to finish the configuration.

After the reconfiguration, the IP address 123.123.123.123 is no longer the default, and the check-box near it is enabled.

IP Address is used in the DNS zone of a domain:

Using the query below, you may find the domain that uses the IP address 123.123.123.123.

    # MYSQL_PWD=`cat /etc/psa/.psa.shadow` mysql -u admin psa -Ne"select d.name from domains d, dns_recs dns where d.dns_zone_id=dns.dns_zone_id and dns.val='123.123.123.123'"
+-------------+
| name |
+-------------+
| example.com |
+-------------+

After the domain is found, remove or change the IP address in its DNS zone:

Domains > example.com > DNS Settings

This should make the check-box near the IP address enabled on the IP addresses management page.

Have more questions? Submit a request
Please sign in to leave a comment.