Emails can be sent and received, but cannot be forwarded or replied

Refers to:

  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux
  • Plesk 12.5 for Windows

Created:

2016-11-16 13:14:43 UTC

Modified:

2016-12-21 20:16:32 UTC

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Emails can be sent and received, but cannot be forwarded or replied

Symptoms

  1. Emails can be sent and received, but cannot be forwarded or replied
  2. Website is not accessible with HTTP Error 503

In all cases the following error appears in log:

ModSecurity: Access denied with code 403 (phase 2). Match of "rx (^w3c-|systran\\\\\\\\))" against "REQUEST_HEADERS:User-Agent" required. [file "/etc/httpd/conf/modsecurity.d/rules/tortix/modsec/20_asl_useragents.conf"] [line "161"] [id "330039"] [rev "4"] [msg "Atomicorp.com WAF Rules: Suspicious Unusual User Agent (libwww-perl).  Disable this rule if you use libwww-perl. "] [severity "CRITICAL"] [hostname "1.2.3.4"] [uri "/server-status"] [unique_id "U5PJ09Xv30kAAGRwKIEAAAAE"]

Cause

Web Application Firewall (ModSecurity) is blocking access.

Resolution

Whitelist the IP address which is being blocked:

  1. Go to Plesk > Tools & Settings > Web Application Firewall (ModSecurity)
  2. In Switch off security rules section specify the rule ID taken from the log ([id "330039"] in the example above) and click OK .
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