Plesk is not working. Unable to read class.Conf.php3.

Created:

2016-11-16 13:14:42 UTC

Modified:

2017-08-16 17:16:29 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk is not working. Unable to read class.Conf.php3.

Applicable to:

  • Plesk 11.x for Linux

Symptoms

Plesk is showing error:

Warning: file(/etc/psa/psa.conf): failed to open stream: No such file or directory in /usr/local/psa/admin/plib/class.Conf.php3 on line 27
Unable to read Control Panel configuration file: date_default_timezone_get() [function.date-default-timezone-get]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead

Cause

Packages " plesk-base ", " plesk-core " or " psa " are corrupted.

Resolution

  1. Check the file existance and to which package it belongs to:

    # ll /usr/local/psa/admin/auto_prepend/auth.php3
    -rw-r--r-- 1 root root 18679 May 9 08:17 /usr/local/psa/admin/auto_prepend/auth.php3

    #rpm -qf /usr/local/psa/admin/auto_prepend/auth.php3
    psa-11.0.9-cos6.build110120608.16.x86_64
  2. Download the packages from autoinstall.plesk.com and reinstall them, if needed:

    # rpm -Uvh plesk-base-11.0.9-cos5.build110121128.16.i386.rpm --force
    # rpm -Uvh psa-11.0.9-cos5.build110120608.16.i386.rpm --force
  3. Change Plesk admin password using /en/213364309 and re-install microupdates .

Have more questions? Submit a request
Please sign in to leave a comment.