Mail to non-existent users is bounced: Recipient address rejected: User unknown in virtual mailbox table

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:14:22 UTC

Modified:

2017-01-30 13:07:33 UTC

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Mail to non-existent users is bounced: Recipient address rejected: User unknown in virtual mailbox table

Symptoms

When sending an email to a non-existent user (i.e. test@example.com), which is in Subscription domain , the email is forwarded to an external address (i.e. externalemail@someserver.tld) as per the 'What to do with mail sent to nonexistent users' option under the 'Mail settings'.

Additionally, if the email is sent to a non-existent user (i.e. nonexistuser@domainadd.tld), which is in additional domain, NOT in the Subscription domain (i.e. example.com), a bounce back with the following error is received:

Recipient address rejected: User unknown in virtual mailbox table

Cause

"catch-all" address is not set for the additional domains.

Resolution

Update bounce settings for the affected domains by executing the following command:

# /usr/local/psa/bin/subscription_settings -u <affecteddomain.tld> -no_usr <catch-all@example.com>
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