Installation of Plesk updates fails: can't apply patch

Created:

2016-11-16 13:14:19 UTC

Modified:

2017-04-24 11:42:08 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Installation of Plesk updates fails: can't apply patch

Applicable to:

  • Plesk 11.5 for Windows
  • Plesk 12.0 for Windows
  • Plesk 12.0 for Linux
  • Plesk 12.5 for Windows

Symptoms

Installation of Plesk updates fails with error:

Error: can't apply patch panel-12.5.30~patch7
Unable to set the object (C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\htdocs\\server\\.aiupd_32132\\mail.php3) owner: (5) Access is denied.
Warning! Not all packages were installed.
Please check if your system services are operable.
Please try installing packages again later.
Please resolve this issue and try installing the packages again.
If you cannot resolve the issue on your own, contact product technical support for assistance.

Cause

  1. Antivirus software is blocking access to C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\htdocs\\server\\.aiupd_32132 folder
  2. Insufficient permissions for C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\htdocs\\server\\.aiupd_32132

Resolution

  1. Turn off the antivirus or make sure Plesk installer "%plesk_bin%"\\ai.exe is allowed in its configuration.

  2. Make sure vaild permissions are set for psaadm , psaserv and psacln users for the folder:

    "%plesk_dir%"\\admin\\htdocs\\>icacls server | findstr psa
    server WIN\\psacln:(I)(OI)(CI)(N)
    WIN\\psaserv:(I)(OI)(CI)(N)
    WIN\\psaadm:(I)(OI)(CI)(IO)(RX)

correct them if required:

    cd "%plesk_dir%"\\admin\\htdocs\\
icacls server /grant psaadm:(OI)(CI)(IO)(RX)
icacls server /grant psaserv:(OI)(CI)
icacls server /grant psacln:(OI)(CI)
  1. Reinstall Plesk updates:
    %plesk_dir%\\admin\\bin\\ai.exe --select-product-id panel --select-release-current --reinstall-patch --install-component base
Have more questions? Submit a request
Please sign in to leave a comment.