Plesk upgrade fails with error: " dependency problems prevent configuration of bind9"

Created:

2016-11-16 13:14:14 UTC

Modified:

2017-08-16 17:01:56 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade fails with error: " dependency problems prevent configuration of bind9"

Applicable to:

  • Plesk 11.x for Linux

Symptoms

Could not upgrade Plesk Panel to the 11.5 version, upgrade fails with error below:

bind9 depends on bind9utils (= 1:9.8.1.dfsg.P1-4ubuntu0.6); however:
Version of bind9utils on system is 1:9.8.1.dfsg.P1-4ubuntu0.7.

dpkg: error processing bind9 (--configure):
dependency problems - leaving unconfigured

Cause

Bind package could not be installed because of dependencies: some packages of higher version are already installed.

Resolution

  1. Downgrade all the packages from error to the required version, for example in this case it is needed to downgrade bind9utils package to the 1:9.8.1.dfsg.P1-4ubuntu0.6 version:

    bind9 depends on bind9utils (= 1:9.8.1.dfsg.P1-4ubuntu0.6); however:
    Version of bind9utils on system is 1:9.8.1.dfsg.P1-4ubuntu0.7.
  2. Try to perform upgrade ones again.

Have more questions? Submit a request
Please sign in to leave a comment.