Plesk upgrade from templates failed - Unable to locate package php

Created:

2016-11-16 13:14:13 UTC

Modified:

2016-12-21 20:15:21 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade from templates failed - Unable to locate package php

Symptoms

Plesk upgrade task in OA failed:

Task name:  Install set of VZ templates to VPS domain.tld

Queue status: Failed

Last execution output: Internal error: 3501 : Can not install packages: ' vzpkg install -q 20393 .pp11-mod-cloudflare .pp11-kav .pp11-cf-support .pp11-tomcat .pp11-migration .pp11-billing .pp11-watchdog .pp11-gameservers .pp11-php5 .pp11-postfix' exec failed - W: GPG error: http://security.ubuntu.com precise-security Release: No keyring installed in /vz/tmp//vzpkg.p8Ij3V/trusted.gpg.d/.
W: GPG error: http://archive.canonical.com precise Release: No keyring installed in /vz/tmp//vzpkg.p8Ij3V/trusted.gpg.d/.
...
E: Unable to locate package php
E: Unable to locate package php-gd
E: Unable to locate package php-imap
E: Unable to locate package php-mbstring
E: Unable to locate package php-mysql
E: Unable to locate package php-xml
E: Unable to locate package php-cli
E: Unable to locate package php-pdo
E: Unable to locate package php-common
Error: /usr/bin/apt-get failed, exitcode=100

Cause

' /vz/template/ubuntu/12.04/x86_64/config/app/pp11-php5/default/packages ' file contains incorrect package names:

# rpm -qf /vz/template/ubuntu/12.04/x86_64/config/app/pp11-php5/default/packages
pp11-php5-ubuntu-12.04-x86_64-ez-4.0.0-36.prl.312714.noarch

# cat /vz/template/ubuntu/12.04/x86_64/config/app/pp11-php5/default/packages
psa-php5-configurator
php5-ioncube-loader
php
php-gd
php-imap
php-mbstring
php-mysql
php-xml
php-cli
php-pdo
php-common
psa11-php-fakepackage

This is Plesk internal issue PPPM-283 , which is expected to be fixed in future Plesk updates.

Workaround

Remove the following lines from the file:

php
php-gd
php-imap
php-mbstring
php-mysql
php-xml
php-cli
php-pdo
php-common

Then, re-run the failed Plesk upgrade task in OA, when it is convenient for the customer.

Have more questions? Submit a request
Please sign in to leave a comment.