Applicable to:
- Plesk 11.x for Windows
- Plesk 12.0 for Windows
- Plesk 12.5 for Windows
- Plesk Onyx for Windows
Symptoms
Not able to register MS SQL database server in Plesk > Tools & Settings > Database servers - Add new database server
Cause
There may be several different issues in MS SQL connection configuration:
-
MS SQL configured to run as
'Localservice'
or'Networkservice'
accounts -
'sa'
password may be not correct - Instance name may be not correct, etc.
Resolution
In order to check all these settings, complete the steps below:
-
Check how the service is configured to run on the server, as
'Localservice'
or'Networkservice'
accounts. To do that go to Run > Services.msc
1.1. If the database server is local then MS SQL database service is configured to run as
'Localservice'
:
* Add server as `'localhost'` (or direct instance name like `.\\MSSQLSERVER2012`) in Plesk.
1.2. If Database server is configured as to run as `'Networkservice'`
* Add IP address along with the instance name, example: `(192.168.21.211\\MSSQLSERVER2012)`
-
In case of multiple
MS SQL
database server instances available on the server, check the particular instance name by using'Services.msc'
or'SQL Server configuration manager'
-
Try to connect
MS SQL
with the same settings as you use to access theMS SQL management studio
(usually username'sa'
and password) -
If you do not have
'sa'
password, you can reset the password through MSSQL Management Studio > Security > Logins > sa user properties > Password or through command line
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