Plesk upgrade failed: ERROR while trying to execute SQL query: REPLACE INTO meta_info

Created:

2016-11-16 13:13:43 UTC

Modified:

2017-08-16 18:29:46 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade failed: ERROR while trying to execute SQL query: REPLACE INTO meta_info

Applicable to:

  • Plesk 11.x for Linux
  • Plesk 12.0 for Linux

Symptoms

Plesk upgrade failed with error:

ERROR while trying to execute SQL query, the query was: REPLACE INTO meta_info (param, value) VALUES ('db_version', '012000018')
Check the error reason(see log file: /tmp/plesk_12.0.18_installation.log), fix and try again

Cause

Table apsc.meta_info does not exist or corrupted.

Resolution

  1. Make sure that apsc database contains meta_info table:

    # mysql -u admin -p`cat /etc/psa/.psa.shadow` apsc

    mysql> select * from meta_info;
    ERROR 1146 (42S02): Table 'apsc.meta_info' doesn't exist
  2. If the mentioned table meta_info does not exist, create it as below:

    CREATE TABLE `meta_info` (
    `param` varchar(255) CHARACTER SET ascii COLLATE ascii_bin NOT NULL,
    `value` varbinary(2000) NOT NULL,
    PRIMARY KEY (`param`)
    );
  3. Continue upgrade.

Have more questions? Submit a request
Please sign in to leave a comment.