How to enable ASP.NET 2.0/3.5 on Windows Server 2012 and higher

Created:

2016-11-16 13:12:59 UTC

Modified:

2017-08-23 06:02:24 UTC

35

Was this article helpful?


Have more questions?

Submit a request

How to enable ASP.NET 2.0/3.5 on Windows Server 2012 and higher

Applicable to:

  • Plesk Onyx for Windows
  • Plesk 11.x for Windows
  • Plesk 12.0 for Windows
  • Plesk 12.5 for Windows

Question

There is no ASP.NET 2.0 or ASP.NET 3.5 in Domains > example.com > Hosting Settings > Microsoft ASP.NET support .

How can ASP.NET 2.0/3.5 be enabled?

Answer

On Windows Server 2012 and higher, ASP.NET 2.0 and 3.0 are included in ASP.NET 3.5 . In order to enable this ASP.NET version, follow the steps below:

  1. Go to Server Manager > Manage > Add Roles and Features

  2. In Server Roles select Web Server (IIS) > Web Server > Application Development > ASP.NET 3.5, .NET Extensibility 3.5:

  3. In Features select .NET Framework 3.5 Features > .NET Framework 3.5:

  4. Click Install

  5. Go to Plesk > Tools & Settings > Server Components and click Refresh to detect ASP.NET 3.5 .

  6. Verify that ASP.NET 3.5 is shown in Tools & Settings > ASP.NET Settings and in Hosting Settings of domains .

Supported ASP.NET versions:

Have more questions? Submit a request
Please sign in to leave a comment.