Parallels Web Presence Builder 11.0: Contact Form issues

Created:

2016-11-16 13:12:53 UTC

Modified:

2017-08-16 17:19:29 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Parallels Web Presence Builder 11.0: Contact Form issues

Applicable to:

  • Web Presence Builder for Linux
  • Plesk 11.x for Windows
  • Plesk 11.x for Linux

Symptoms

We're experiencing an issue with Parallels Web Presence Builder 11.0, with the " Contact Form " module inside of WPB.The customers are not receiving email when the form is filled. Also Captcha does not work.

Cause

" Contact From " emails are sent via PHP function mail from the server where to the site is published (where the domain is located).

  1. Server " host " where to the site is published is out of free disc space:

    [root@host ~]# df
    Filesystem 1K-blocks Used Available Use% Mounted on
    /dev/sda1 45067080 43826804 0 100% /
  2. PHP functions " exec ", " popen ", " pclose " and others are disabled in configuration file on the publishing server " host ":

    [root@host ~]# grep disable /etc/php.ini
    disable_functions = system,apache_note,apache_setenv,closelog,debugger_off,openlog,syslog,popen,pclose,exec
  3. Outdated Captcha of Parallels Web Presence Builder 11.0.

Resolution

  1. Release some or add more disc space to the publishing server " host ".
  2. Enable PHP functions " exec ", " popen ", " pclose " at least, test other functions.
  3. Upgrade your edition of Parallels Web Presence Builder to version 11.5 that works with reCAPTCHA .

Additional information

Release Notes for Parallels Presence Builder 11.5 for Parallels Automation

Release Notes for Parallels Presence Builder 11.5 Standalone

Parallels Presence Builder 11.5 for Plesk Linux

Parallels Presence Builder 11.5 for Plesk Windows

Have more questions? Submit a request
Please sign in to leave a comment.