Language Switcher module is not visible in Web Presence Builder after it was added

Refers to:

  • Web Presence Builder 12.0 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:12:47 UTC

Modified:

2016-12-21 20:12:17 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Language Switcher module is not visible in Web Presence Builder after it was added

Symptoms

After adding Language Switcher module it is not visible in Web Presence Builder editor:

  1. Module was added to site in Web Presence Builder editor.

  2. After site was opened in editor again, module Language Switcher is not visible.

  3. Even if it is visible it can not be removed and not all selected languages are displayed.

Cause

Caused by software issue with id PPB-4384 . It was fixed in Web Presence Builder 12.0.7.

Resolution

  • Plesk:

    Issue was fixed in Plesk 12 MU#29: Plesk 12 Release Notes .
    Install latest Plesk microupdates.

  • WPB Standalone & WPB for OSA:

    Upgrade Web Presence Builder to the latest version.

Workaround

Note: Only for WPB 12.0.6 in OSA

  1. Backup files on Web Presence Builder centralized instance

    <wpb installation path>/htdocs/js/minimized/Editor.js
    <wpb installation path>/htdocs/js/Sb/widget/Language.js
  2. Replace them with the patched ones .

    Note: Web Presence Builder installation path looks like:

    /usr/local/pem/vhosts/*****/webspace/siteapps/**/
Have more questions? Submit a request
Please sign in to leave a comment.